Feature: #93631 - Support for PHP 8.0

See Issue #93631

Description

TYPO3 Core is now compatible with PHP 8.0, which is officially supported with security updates until 26th November 2023.

Impact

TYPO3 can now be installed on systems running with PHP 8.0.