TYPO3 Exception 1482394401

Note

Below, the TYPO3 community may have provided additional information or solutions for this exception. However, these may or may not apply to your particular case. If you can provide more information, you should come back here and add your experience and solution steps to this issue once you have resolved it.

General TYPO3 troubleshooting tips can be found in the section “Troubleshooting” of the menu, and live support is available in the TYPO3 Slack channel #typo3-cms.

To add your experience, click “Edit on GitHub” above and follow the “Edit on GitHub” workflow. Also check out our tip on Coding Style and reST.

Missing “type” in TCA of field

Using form finishers

Enabling in the Form plugin the “Override finisher settings” option may display this error for wrongly configured form finishers.

Solution

Comment out one finisher at a time in the form definition file (*.form.yaml) to find the culprit.

Using TCEforms FlexForm

The error message only gives an example table

name and table field, because due to some migration to real names are not used in this error message. So you have to do some guesswork from which extension causes this error. Check the FlexForm file FlexForm_ds.xml (or another name) of the extension if there are TCEforms entries. In the child pair config a type must have been defined.

Example:

<config>
  <form_type>user</form_type>
  <userFunc><![CDATA[EXT:myextension/lib/class.tx_myextension_tceFunc.php:&tx_myextension_tceFunc->getCheckbox]]></userFunc>
  <checked>0</checked>
</config>

You must use the type instead:

<type>user</type>