Deprecation: #86068 - old condition syntax

See Issue #86068

Description

The Symfony expression language is available for TypoScript since Issue #85829 has been merged. Accordingly the classic TypoScript condition syntax has been marked as deprecated.

For detailed information about the new expression language see #85829.

Impact

Using the old condition syntax will trigger a PHP E_USER_DEPRECATED error.

Also the combination of multiple condition blocks with AND, OR, && and || has been marked as deprecated and will trigger a PHP E_USER_DEPRECATED error.

If this is not possible yet to fully migrate to Symfony expression language, the feature flag [SYS][features][TypoScript.strictSyntax] can be disabled via Settings -> Configure Installation-Wide Options or directly in LocalConfiguration.php.

Affected Installations

TYPO3 installations with extensions which define conditions using the old syntax or setups which make use of the old condition syntax.

Migration

The old conditions can be replaced with the new expression language.