Feature: #83038 - Introduce Yarn as dependency manager for node modules

See Issue #83038

Description

Because of the broken dependency manager logic in NPM we have introduced yarn as dependency manager for node modules.

To install node modules you have to install yarn first and call yarn install, do not use yarn update until you really want update a dependency.

Impact

npm should not be used to ensure installing the correct versions.