TYPO3 Exception 1297759968

Note

Below, the TYPO3 community may have provided additional information or solutions for this exception. However, these may or may not apply to your particular case. If you can provide more information, you should come back here and add your experience and solution steps to this issue once you have resolved it.

General TYPO3 troubleshooting tips can be found in the section “Troubleshooting” of the menu, and live support is available in the TYPO3 Slack channel #typo3-cms.

To add your experience, click “Edit on GitHub” above and follow the “Edit on GitHub” workflow. Also check out our tip on Coding Style and reST.

Exception while property mapping at property path “”:Object with identity “1” not found.

This error is thrown when a link to a hidden record is called.

Exception while property mapping at property path “”:Method::__construct() does not exist

The ReflectionService tries to get the constructor arguments of your model class, which in this case seem not to exist.

As a work around you can put an empty __construct method in your model class

/**
 *
 */
public function __construct() {
}

Exception while property mapping at property path “”:Could not find a suitable type converter for “array|null” because no such class or interface exists

See https://forge.typo3.org/issues/48172

Try updating the relevant extensions and TYPO3. If everything is up-to-date and the error still occurs setting the TypoScript option plugin.tx_news.features.rewrittenPropertyMapper = 0 may help.

Hint

Enabling/disabling the rewrittenPropertyMapper has huge impacts on extbase behaviour. You are strongly advised to learn about the “new” propertyMapper and how to use/configure it rather then deactivating it.

Exception while property mapping at property path “”: Could not find a suitable type converter for “…” because no such class or interface exists.

After adding an new model and clearing the caches (BE -> Flush system caches, rm -rf typo3temp/Cache/), the new class still was not found. Deactivating and reactivating the extension was solution.

Background: the autoload information (typo3temp/autoload/) wasn’t flushed/updated. Since TYPO3 v8 there’s a option in the install-tool for regenerating the autoconfiguration files.

Exception while property mapping at property path “…”: Could not determine the child object type.

Try clearing all caches.

Try to truncate the cf_extbase_reflection table after you modified the model.

Exception while property mapping at property path “Property 0” was not found in target object of type “…”

When using extended models you need to set the base class variables to protected instead of private.

Another solution could be to truncate the “cf_extbase_reflection” table

This error is also displayed if a property in a fluid-form is wrong. In my case I had property=”{object.propertyName}” instead of property=”propertyName”

Exception while property mapping at property path “…”:No converter found which can be used to convert from “array” to “string”.

The solution is there: http://stackoverflow.com/questions/16405963/typo3-how-to-use-file-upload-with-extbase

Exception while property mapping at property path “It is not allowed to map property “badproperty”. …”

If badProperty is an ObjectStorage that holds references to other models and you want to edit this relation in a Fluid form with a multiselect or checkboxes, don’t let Fluid convert your objects. So instead of doing this:

<f:form.checkbox property="yourProperty" value="{someObject}" />

assign only the uid integers to the viewhelper, like this:

<f:form.checkbox property="yourProperty" value="{someObject.uid}" />

Exception while property mapping at property path “”:The target type was no string, but of type “NULL”

See https://forge.typo3.org/issues/66049

This issue concerning passing an array of objects to a controller action should have been resolved in 7.x because the old property mapper has been removed completely.

Exception while property mapping at property path “”: Path does not exist in array

When resetting options in YAML config files for EXT:form write

formEditor:
  editors:
    700: null

instead of

formEditor:
  editors:
    700:
      identifier: null
      templateName: null

Exception while property mapping at property path “propertyname”: The identity property “” is no UID.

TYPO3 expects a relation as a property and can’t find it. Check if a related database record exists (here: at “propertyname”) and make sure to catch the error if no relation is present.