Installation

With Composer

If your TYPO3 installation is using Composer, install the extension fluid_styled_content by:

composer require typo3/cms-fluid-styled-content

If you are not working with the latest version of TYPO3 you will need to add a version constraint:

composer require typo3/cms-fluid-styled-content:"^10.4"

Installing the extension prior to TYPO3 11.4

Before TYPO3 11.4 it was still necessary to manually activate extensions installed via Composer using the Extensions module.

If you are using TYPO3 with Composer and are using a version of TYPO3 that is older than 11.4, you will need to activate the extension:

  • Access Admin Tools > Extensions > Installed Extensions
  • Search for fluid_styled_content (note the underscores)
  • Activate the extension by selecting the Activate button in the column labeled A/D

Without Composer

If you are working with a legacy installation of TYPO3, this extension will already be part of the installation due to the fact that “classic” .tar & .zip packages come bundled with all system extensions.

However, whilst the extension is already downloaded, it might not be activated.

To activate the extension fluid_styled_content, navigate to Admin Tools > Extensions > Installed Extensions and search for fluid_styled_content (note the underscores). If the extension is not active, activate it by selecting the Activate button in the column labeled A/D.

Activate the extension by clicking the Activate button.

Activate the extension by clicking the Activate button.

System Maintainer rights are required to activate the extension.

Upgrade

If you upgrade your TYPO3 CMS installation from one major version to another (for example 10.4 to 11.5), it is advised to run the Upgrade Wizard. It guides you through the necessary steps to upgrade your database records.

Open the tool at Admin Tools > Upgrade > Upgrade Wizard and run all suggested steps.

Next step

Include the default TypoScript template.